Cisco Switch configuration Step by Step

NetworkTutor
NetworkTutor
1.5 هزار بار بازدید - 4 سال پیش - This is part 2 of
This is part 2 of the Cisco Switch configuration  Step by Step  
You can watch the part one using this like:
How to configure cisco switch step by...

In this video I will be covering the how to use vim text editor for your day to day network configuration and how to speed up the configuration by copy and past from a text editor. I am taking advantage of steps 1-6 that I covered in my first video and showing here how you can do the configuration fast.

Also I am covering how to configure vlans, interface range command, how to configure ports for a vlan and how to shut unwanted ports. Finally I covered how to save configuration.

If you are preparing for CCNA exam - these videos will be very helpful.

Commands Used:
----------------------------
Cisco Switch configuration - Step-by-Step - Part 1/2
==========================================
1. Assign host name
--------------------
host abc-s-marketing-b101-1-access

2. Configure Management IP and shut vlan 1
-------------------------------------------
interface Vlan1
no ip address
shutdown

interface vlan 499
ip address 10.134.56.6 255.255.255.0
exit

3.Assign a Default Gateway
--------------------------
ip default-gateway 10.134.56.252


4. Enable Secrect Password Config
----------------------------------
enable secret KeyLess123!!


5. Configure Telnet and Console Access Passwords
------------------------------------------------
Telnet
------
line vty 0 15
password KeyLess123!!
login
exit

Console
-------
line console 0
password KeyLess123!!
login
exit

6.Configure ACL and assign it to Telnet access
----------------------------------------------
ip access-list standard TELNET-ACCESS
permit  10.155.16.0 255.255.255.0
permit  10.176.20.0 255.255.255.0
permit host 144.92.200.254
exit

line vty 0 15
access-class TELNET-ACCESS in
exit


7. Configure Layer2 VLANs and assign ports to the them
-------------------------------------------------------
By default, all physical ports of the switch belong to the native VLAN1
We will create two new vlans (VLAN50 and VLAN51) and assign five ports to each one
Vlan50 - Marketing
Vlan51 - Finance

Now assign ports 1-5 to vlan50 and ports 6-10 to vlan 51


8. Disable unneeded ports on the switch
----------------------------------------
This is one of the best practices that enhance network security.
interface range gig 0/11-24
shut
exit

9. Save the configuration
--------------------------
wri
or
wri mem
or
copy run start








Cisco Switch configuration - Step-by-Step
=========================================
1. Assign host name
--------------------
host abc-s-marketing-b101-1-access

2. Configure Management IP and shut vlan 1
-------------------------------------------
interface Vlan1
no ip address
shutdown

interface vlan 499
ip address 10.134.56.6 255.255.255.0
exit

3.Assign a Default Gateway
--------------------------
ip default-gateway 10.134.56.252


4. Enable Secrect Password Config
----------------------------------
enable secret KeyLess123!!


5. Configure Telnet and Console Access Passwords
------------------------------------------------
Telnet
------
line vty 0 15
password KeyLess123!!
login
exit

Console
-------
line console 0
password KeyLess123!!
login
exit

6.Configure ACL and assign it to Telnet access
----------------------------------------------
ip access-list standard TELNET-ACCESS
permit  10.155.16.0 255.255.255.0
permit  10.176.20.0 255.255.255.0
permit host 144.92.200.254
exit

line vty 0 15
access-class TELNET-ACCESS in
exit


7. Configure Layer2 VLANs and assign ports to the them
-------------------------------------------------------
By default, all physical ports of the switch belong to the native VLAN1
We will create two new vlans (VLAN50 and VLAN51) and assign five ports to each one
Vlan50 - Marketing
Vlan51 - Finance

Now assign ports 1-5 to vlan50 and ports 6-10 to vlan 51


8. Disable unneeded ports on the switch
----------------------------------------
This is one of the best practices that enhance network security.
interface range gig 0/11-24
shut
exit

9. Save the configuration
--------------------------
wri
or
wri mem
or
copy run start
4 سال پیش در تاریخ 1399/08/10 منتشر شده است.
1,565 بـار بازدید شده
... بیشتر